home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / app-shells / tcsh-6.14-r2 / tcsh-6.14-r2.ebuild < prev    next >
Text File  |  2006-01-09  |  2KB  |  84 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.14-r2.ebuild,v 1.11 2006/01/02 17:35:00 hansmi Exp $
  4.  
  5. inherit eutils
  6.  
  7. MY_P="${P}.00"
  8. DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
  9. HOMEPAGE="http://www.tcsh.org/"
  10. SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
  11.     mirror://gentoo/${P}-conffiles.tar.bz2"
  12. # note: starting from this version the various files scattered around
  13. #       the place in ${FILESDIR} are now stored in a versioned tarball
  14.  
  15. LICENSE="BSD"
  16. SLOT="0"
  17. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
  18. IUSE="perl"
  19.  
  20. DEPEND=">=sys-libs/ncurses-5.1
  21.     perl? ( dev-lang/perl )"
  22.  
  23. S=${WORKDIR}/${MY_P}
  24.  
  25.  
  26. src_unpack() {
  27.     unpack ${A}
  28.     epatch "${FILESDIR}"/${P}-r2.patch
  29. }
  30.  
  31. src_compile() {
  32.     econf --prefix=/ || die "econf failed"
  33.     emake || die "compile problem"
  34. }
  35.  
  36. src_install() {
  37.     make DESTDIR="${D}" install install.man || die
  38.  
  39.     if use perl ; then
  40.         perl tcsh.man2html || die
  41.         dohtml tcsh.html/*.html
  42.     fi
  43.  
  44.     insinto /etc
  45.     doins \
  46.         "${WORKDIR}"/gentoo/csh.cshrc \
  47.         "${WORKDIR}"/gentoo/csh.login
  48.  
  49.     insinto /etc/skel
  50.  
  51.     insinto /etc/profile.d
  52.     doins \
  53.         "${WORKDIR}"/gentoo/tcsh-bindkey.csh \
  54.         "${WORKDIR}"/gentoo/tcsh-settings.csh
  55.  
  56.     dodoc FAQ Fixes NewThings Ported README WishList Y2K
  57.  
  58.     docinto examples
  59.     dodoc \
  60.         "${WORKDIR}"/gentoo/tcsh-aliases \
  61.         "${WORKDIR}"/gentoo/tcsh-complete \
  62.         "${WORKDIR}"/gentoo/tcsh-gentoo_legacy \
  63.         "${WORKDIR}"/gentoo/tcsh.config
  64. }
  65.  
  66. pkg_postinst() {
  67.     # add csh -> tcsh symlink only if csh is not yet there
  68.     [ ! -e /bin/csh ] && dosym /bin/tcsh /bin/csh
  69.  
  70.     while read line; do einfo "${line}"; done <<EOF
  71. The default behaviour of tcsh has significantly changed starting from
  72. version 6.14-r1.  In contrast to previous ebuilds, the amount of
  73. customisation to the default shell's behaviour has been reduced to a
  74. bare minimum (a customised prompt).
  75. If you rely on the customisations provided by previous ebuilds, you will
  76. have to copy over the relevant (now commented out) parts to your own
  77. ~/.tcshrc.  Please check all tcsh-* files in
  78. /usr/share/tcsh-6.14-r2/example and include their behaviour in your own
  79. configuration files.
  80. The tcsh-complete file is not any longer sourced by the default system
  81. scripts.
  82. EOF
  83. }
  84.